Treehugger

Interior lights won't turn off

34 posts in this topic

Here is the scoop - at lunch time today my interior lights turned on and have not turned off since. I have:1. Checked the doors - they are closed2. Checked the hatch - window and door - they are closed3. Checked the switch on the dash - it's offThe lights have now been on for about 4 hours. They won't do the "auto" shut off after five minutes, they won't fade, they just stay lit. My dealer, in their brilliance has told me to come in tomorrow afternoon or the next morning (I think my battery might be dead by then...... :banghead: ) or call roadside assistance.Does anyone else have any ideas? :scowl:

Share this post


Link to post
Share on other sites

I don't. You checked all the usual suspects.You might want to take your car out for a 20 minute drive before you retire for the night just to charge up the battery.Later! Dang

Share this post


Link to post
Share on other sites

Whip the bulbs out pending a repair.

Share this post


Link to post
Share on other sites

Whip the bulbs out pending a repair.

Or pull the fuse. Middle row, second one in, brown in color. That light is gonna be hot.RCAF

Share this post


Link to post
Share on other sites

Dont take this the wrong way...its just a suggestion based on the problems people have had in the past. But the "off" position for the dash switch is actually UP and not down like a household light switch. If you tried that already thats great other than it means you need a plan B until it gets looked at...I'd pull the light fuse rather than trying to get the bulbs out. Less chance of damaging the car and burning yourself.

Share this post


Link to post
Share on other sites

I went out to take the fuse out and realized my card for roadside assistance was in the house - I cursed VERY LOUDLY at this point, went in the house, came out.......and the light was off.I think I scared The Flea into submission......... :dominate: When I came in my wife asked "Did you fix it?"I replied, "Of course - it was no problem," and then went for the Havana Club.

Share this post


Link to post
Share on other sites

The "door ajar" light only works for the driver's door (on mine anyway). If the passenger door is not fully latched the lights will stay on, with no "door ajar" light showing.

Share this post


Link to post
Share on other sites

I think it must have had some weird electrical thing going on that "fixed" itself. As long as I don't wake up to see a pile of melted plastic and ashes in my garage I'm happy. On the other hand, my garage COULD use some work....hmmmm.

Share this post


Link to post
Share on other sites

I had the same problem recently. The light would go off if we locked the doors at least. It has misteriously fixed itself now... :dunno:

Share this post


Link to post
Share on other sites

Hi My front (not rear) interior light came on this afternoon, during a 90km journey. I checked doors and back etc and still it stayed on. Then this evening, the front left headlight & sidelight are not working. Is this just a coincidence? Does the front interior light come on (it's still on) if there is a problem with a bulb?Any advice will be appreciated as the manul is a bit unforthcoming :banghead: ThanksLaineha

Share this post


Link to post
Share on other sites

Mine has done this 2 times, I opened and slamed both doors, them 30 seconds later, it went out.It may be a faulty door switch

Share this post


Link to post
Share on other sites

OK thanks, I'll go and try that, hopefully it will work...I have a 2005 black on black pulse too!Laineha

Share this post


Link to post
Share on other sites

HiWell, I tried SLAMMING everything (quiet neighbourhood, late at night, set several dogs off) and something must have worked. Either that or the fact that my darling husband came out and just switched it off. I maintain that I did already try that; he just smiles indulgently...Thank you :fixed: TTFN Laineha

Share this post


Link to post
Share on other sites

On a somewhat related topic: I distinctly remember the dimmer switch and cigarette lighter trim ring being illuminated, but I can't remember the last time I saw them lit. Am I delusional?

Share this post


Link to post
Share on other sites

Yes ;)Neither are/rwere illuminated.When you put the OEM smart fog light switch in, its symbol is illuminated, however.

Share this post


Link to post
Share on other sites

Had that happen to me this morning on my drive in to work... lights stayed on and then, the car wouldn't lock. Tried to lock & unlock it, tried both doors, etc. Even fished out the manual and tried the if-all-else-fails method in there (which didn't work). Still wouldn't lock. Lights still on, but now not the biggest problem. I was running through my mind all the things said on this forum about such situations (which fuse was it for the light; etc-- thanks guys, you helped avoid (a) panic and (B) a call to the CAA) as I tried everything I oculd think of. Something worked (not sure what) because it did eventually lock. It showed me the benefits of automatic locks with a key-lock option. Took about 20 minutes of trying, and if I hadn't been able to solve it, don't know what I would have done because can't leave it unlocked and there was no way to get it locked. Didn't even want to see if the damned lights finally went off :)Any ideas what could have caused such a problem?! I've had the car for only a week now, but it was bought used.Aliza

Share this post


Link to post
Share on other sites

One side of your tailgate may not have been latched properly. Or one door.

Share this post


Link to post
Share on other sites

I know this thread is a few months old, but this is my first submission to Club Smart Forum. B) It is approaching the 1st anniversary for "our" 2006 Cabrio and this is the first problem I have had with the car. Put on 14,000 km with only the regular oil service at the dealership. This little Smart has done very well, even TWO road trips to New York City. He loved that. The little Frenchmen in the Big Apple!Like the other contributors I have had TWO cases over the past couple weeks where I can't lock the doors and the Dome light stays on. The car even "beeps" at me as I am driving. If I take my foot off break and gas it would switch to "O". In both cases the poltergeist fault seems to correct itself. I was so frustrated I drove to the dealer with the light on, car beeping and when I pulled into the service bay it was gone!I have tried, like everyone else, slam doors, even open/close roof. Still was there. I am wondering if it could be a moisture problem with one of the door sensors. We have had a TON of snow here in Ottawa this year and with the car in-out of our "heated" garage could it be moisture on some sensor?I would like to have some "evidence" to take to the dealer, because as you know, when I took the car in the last time and tried to explain what was wrong the service manager said that they have never heard of this issue.. Dah!Anway. Thanks for a great club site. I have been secretly reading and learning over the year. Perhaps now I can come out and give some advice or input to future threads.Thanks Club Smart members. :) CheersImSmtRu2

Share this post


Link to post
Share on other sites

I don't have a cabrio but, I know in coupe if my driver door sensor is activate then the car will beep as soon as a touch the gas pedal (diesel pedal). On the coupe the same type of sensor does not existing for the passenger door or rear hatch.Does the light turn off eventually, like 15 minutes? I think in the coupe it will. So, I would probably get the dealership to look at the driver door sensor first and go from there.PS: Welcome to the club.

Share this post


Link to post
Share on other sites

Hi, I had the same problem with my 2006 Grandstyle. I removed the interior light bulb and the bulb in the dash light and then discoverd that the dash light was broken. I took it to the dealer who installed a new dash light switch which solved my problem. I also replaced the interior light bulb with an LED bulb to avoid excessive heat so the headliner wouldn't discolor. Cliff - DR MAP

Share this post


Link to post
Share on other sites

Thanks ARTZ. Yes the light eventually goes out and it stops "beeping" at me. I think you are right about the driver door sensor. My daughter drove it the other day and never opened the back or passenger door and it gave her the same problem. We must be getting in and out of the car too much and not spending enough time driving.. ;) If it happens again I will take it in and have them check that sensor.Dr Map. I know my lights are OK, but good point on the LED light. Never thought that may happen. Guess I better go add that to my Christmas list at SmartieParts.Thanks for information. Much appreciated.CheersImSmrtRu2

Share this post


Link to post
Share on other sites

OK, so its not just Orange Crush with the Christine spooked car thing going on.

Today, I drive off and the auto door locks, well...lock. Then unlock. Then lock.

Also, the interior lights stay on. Then flicker off. Then back on.

At stop signs-lights, tranny slips to 0 and I get the beep treatment.

Some Xmas shopping, start stop, in and out, and then all was normal on the return trip.

I had a Volvo with on again off again electrical gremlins, really no fun and

today I had flashbacks to the colossal time and money waste that car turned out to be.

This has to be different. No, really it has to.

Blair

Share this post


Link to post
Share on other sites

It sounds like a wet SAM to me.Has the windscreen been replaced with a non-smart unit? NEVER get a non-smart windscreen....but maybe that's not it.

Share this post


Link to post
Share on other sites

The same sort of things have happened with our 2006 last night and this morning. Pretty well all the same symptoms you guys have mentioned which came out of nowhere. We did have a lot of rain yesterday so I'm thinking that amount of moisture "might" have something to do with it. I also noticed the transmission going to '0' when I was stopped but I thought I might have done something. Good to hear that this has been seen by others. The biggest pain is not being able to lock the darn thing. I doubt the dealer would know what to do unless this has been resolved elsewhere. Not too many smart cars around here so a smaller resource for learning. Nothing worse than when a "smart" car goes "stupid".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

    Chatbox
    You don't have permission to chat.
    Load More