Sign in to follow this  
Followers 0
danno

ABS/Brake System/ESP Warning Lights

15 posts in this topic

Leaving the house yesterday morning, I noticed that the idiot lights for ABS, Brake System (circle with exclamation point) and ESP (triangle with exclamation point) dash indicator lights were still lit once I got to the end of my driveway. I stopped, turned off the car, turned it on again, and the same thing, so I turned around and drove back up the driveway. Tried it again, same thing. Time for the manual - which says "When the ABS system fails, together with the brake system indicator light... Immediately park your car away from moving traffic; secure your car against rolling away if you have to leave it; do not drive any further; Call smartmove Assistance at...."Drat.So what do I do? It's Saturday morning, and we also don't have a dealer in town. I know what I'll do: keep it shut off for five minutes and see what happens. Bingo! The lights go out as usual. Okay, the smart thing is to leave it and have it towed. Too much of a nuisance, and what's the worse that could happen? Brakes fail and I plow into a crowd of children and expectant mothers, killing us all. I figure the odds of that are less than one in four, so I head out on my errands as usual, all without incident. (I also figured that if it were an actual brake failure the idiot lights would still be on.)So, what are the opinions? Just a fluke fault? Serious problem? I checked the Scangauge (didn't think of it until this morning) and it says no codes found.

Share this post


Link to post
Share on other sites

I once had something similar. I turned on the key, then while waiting for the glow plugs to cycle, I plugged in the scanguage (it was summer, and I had the guage in the drawer, so it wouldn't cook). The whole dash stayed lite up when I started the car, and wouldn't go off when I shut off and restarted the car. I shut it off, then waited until I heard the little click of resetting relays (about 15 seconds), then everthing was fine. I have since deliberatey, and successfully recreated the sequence.So, my suggestion is that you ensure the scanguage connections are all tight.MG

Share this post


Link to post
Share on other sites

ABS and ESP not working are pretty serious on a smart, but the brakes will not "fail". You could drive it very slowly and carefully, if you had to.The ScanGauge only diagnoses engine codes.Now that the lights are out, you will be OK, but get it checked and at least the shop should be able to tell you what triggered it.

Share this post


Link to post
Share on other sites

I had this a couple times once. It happened when starting the car, others have had it too. Something about the start sequence and doing something at the same time, like moving the shifter, or plugging in the SG etc. Each time it happened, I just shut off the car, waited for the click sound, then restarted and everything was fine. Has happened for many many months now.

Share this post


Link to post
Share on other sites

These three lights seeem to like to come on together for whatever reason.You "might" want to check for moisture in your battery compartment, but it's probably a bad wire somewhere. No problem driving it until you get it in for service, just be a bit extra careful since you won't have some of the electronic nannies on board.Later! Dang

Share this post


Link to post
Share on other sites

If it's not moisture in the brake pedal switch area (usually fixed pro-actively on an A/B service per TSB)...Another thing to look for is a bunk wire connected to the wheel speed sensors...In my Oldsmobile, I blew threw a puddle and took out my front right wheel speed sensor... Effectively disabling my traction control and ABS...Eddie

Share this post


Link to post
Share on other sites

I had this happen this morning. Was it a coincidence that I was plugging in my Scangauge at the same time? I also noticed that the "Hill Hold" didn't work.Called TPM when I got to work to have it checked out...not possible for 10 days. She said that they suspected a "brake light". Seems strange. When I started to the car to head home, everything was back to normal. I plan to have them check it out anyway.Mark

Share this post


Link to post
Share on other sites

I suspect they meant the brake light switch. I would thought all cars would have been done by now, but if yours hasn't been, there is a recall for the switch that can cause problems.Later! Dang

Share this post


Link to post
Share on other sites

I had this happen this morning. Was it a coincidence that I was plugging in my Scangauge at the same time? I also noticed that the "Hill Hold" didn't work.Called TPM when I got to work to have it checked out...not possible for 10 days. She said that they suspected a "brake light". Seems strange. When I started to the car to head home, everything was back to normal. I plan to have them check it out anyway.Mark

I have had this happen twice while plugging in the scangauge, and one when I actually tried to get the lights by plugging in the scangauge. To clear it, I turned off the key, counted to 15 (heard the relay click), then turned on the key, and waited for the light to go off, started up, and everything has been fine since.MG

Share this post


Link to post
Share on other sites

Guys, when your ABS is "running" and you feel it happening, is the dash light supposed to flicker? I get the ESP light when it's doing its thing but so far I've stopped short (no seinfeld jokes please) to see what the ABS would do and no dash indicator flickers for it.

Share this post


Link to post
Share on other sites

I don't think you get any light for the ABS unless there is a problem with it. When it is working properly, you can feel the pedel pulse, but no light.MG

Share this post


Link to post
Share on other sites

When it is working properly, you can feel the pedel pulse, but no light.MG

Ok, that's what I figured... like my other car...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

    Chatbox
    You don't have permission to chat.
    Load More