Sign in to follow this  
Followers 0
kayble

Odd noise from engine compartment on over run

3 posts in this topic

Dear all,I have an odd noise coming from the engine compartment on my 2001 fortwo CDI that has only recently become apparent.It's a quietish roar on over run. For example, if I accelerate to the point where I'd want to change gears in first or second then simply let go of the accelerator pedal and let the car overrun to a stop, I hear an odd roaring noise associated with engine speed.I don't hear the noise under acceleration or under over run in higher gears.I've just replaced the hose between the turbo and intercooler and performance is back to normal. I have a glow plug warning light illumintated on the dash but believe this to be unrelated. Any ideas?

Share this post


Link to post
Share on other sites

Solved: It was a loose clip on the air filter box casing allowing induction noise to eminate from the loose airbox cover.

Edited by kayble

Share this post


Link to post
Share on other sites

Well that is good. This morning when I read this earlier this morning I was going to ask you about your air filter because I was thinking something about the air flow to the engine, but I wouldn't have thought about it not being fully closed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

    Chatbox
    You don't have permission to chat.
    Load More