Guinness

What Did You Do To Your Smart Today?

4,907 posts in this topic

When I visited the shop the other day to ask if/where they send Bosch smart injectors to be rebuilt, there was a white and green ED in the shop for a brake switch on 8000 km. Apparently it's the same as on the gasser, and essentially the same as the TSB one in the 450.

Share this post


Link to post
Share on other sites

Yeah, I don't know if mine in the 450 was ever changed, even during PDI. There's no record of it. :)

Share this post


Link to post
Share on other sites

Funny that. My first smart ran 247K on its original switch and my C-1 is approaching 70K with no brake switch issues. It may be a "winter area" issue?

Share this post


Link to post
Share on other sites

Think I'm going to grab that box of 25 280 mm bolts. Second major cold snap of the winter this week. I'm tired of no heat so it's time for a new thermostat. 115 km/h for an hour on the highway at +3° and it barely crossed 80° the other day, and the moment I slowed down to 85 in sixth or 65 in fifth (or drove on city streets) the temperature plunged into the 60s.

Share this post


Link to post
Share on other sites

The 451 is at Victoria Star Motors for a new brake lamp switch. The switch is back ordered but they were able to find one at another dealership. smartmove worked well, except having to pay to not have my car taken to M-B London.No previous issue/warning that the switch was failing, unlike the 2 times it has failed in the 450. Rolling in a C250, I dislike them more everytime I have to drive one.

When I visited the shop the other day to ask if/where they send Bosch smart injectors to be rebuilt, there was a white and green ED in the shop for a brake switch on 8000 km. Apparently it's the same as on the gasser, and essentially the same as the TSB one in the 450.

I got 73k km out of the one in my 451.

Yeah, I don't know if mine in the 450 was ever changed, even during PDI. There's no record of it. :)

Funny that. My first smart ran 247K on its original switch and my C-1 is approaching 70K with no brake switch issues. It may be a "winter area" issue?

I'd say it's a winter issue, my switch just showed me the ESP/ABS lights this morning at - 26°, I had the impression this was an improved part.

Share this post


Link to post
Share on other sites

Had to go to the airport to pick up one of my guys, not bothering in taking the 300e or the escape (yeah I own another vehicle) and note able to drive the coupe (mom stole it) I took the Brabus out of storage. Pack up the car open the rear hatch and CRACK there goes the rear window. Apparently -30C without windchill is the limit. . Guess I'm going to have to call up that number and book an appointment with Alpha Auto Trim for a new window. WOOOOAlso it seems my mother has stolen and claimed the coupe and I don't think I'm getting it back anytime soon (unless I have to fix it of course). She can't shift worth a dam and red lines it until it shifts.

Edited by dmoonen

Share this post


Link to post
Share on other sites

Funny that. My first smart ran 247K on its original switch and my C-1 is approaching 70K with no brake switch issues. It may be a "winter area" issue?

Still have my original ebox in the now black (was grey) coupe but i did waterproof the ebox and SAM's in all my smarts. 251,xxxlm really only winter driven. . and driven pretty harshly in any conditions. The Brabus is meant to be away for the winter but is keep on getting summoned out of storage, 169,000km on the clock. The last owner drove it for a couple winters before I bought it.

Share this post


Link to post
Share on other sites

I noticed I had a few high level brake bulbs out when working on the car the other day so I swapped them out for some 1W T5 LEDs.

Posted Image

Posted Image

I also put one in the interior light switch and an LED panel to replace the festoon. The interior is pretty bright now. :)

Share this post


Link to post
Share on other sites

Still have my original ebox in the now black (was grey) coupe but i did waterproof the ebox and SAM's in all my smarts. 251,xxxlm really only winter driven. . and driven pretty harshly in any conditions. The Brabus is meant to be away for the winter but is keep on getting summoned out of storage, 169,000km on the clock. The last owner drove it for a couple winters before I bought it.

My AC was what corroded my ebox. Frost actually builds up on the blower box above the ebox when my AC is on high. It drips on the ebox after I shut off the car. :huh: I relocated the ebox for now. But I think I'm going to adhere some felt or similar to the outside of the blower box to insulate it because it is still dripping down and getting the floor wet under the carpet.

Share this post


Link to post
Share on other sites

Are you sure it is frost? The blower box can fill with water if the AC drain is clogged, causing it to eventually leak. That being said, there are better spots the ebox can be moved to. Mine fits under the centre console, right behind the accessory tree.

Share this post


Link to post
Share on other sites

Are you sure it is frost? The blower box can fill with water if the AC drain is clogged, causing it to eventually leak. That being said, there are better spots the ebox can be moved to. Mine fits under the centre console, right behind the accessory tree.

My AC drain wasn't plugged. It's definitely frost on the outside of the box. You can see it. On a really humid day it can get quite thick. I should've taken a pic of it. lol I relocated mine to the same place you did.

Share this post


Link to post
Share on other sites

Typo, or plan for a group buy?

The latter. I think the plan is the use two of these (with washers) for the rear and the two rear bolts for the front.With tax the bolts work out to around $6.50 each. I have no idea what the cheapest shipping around the country would be, probably regular parcel post for most places.

Share this post


Link to post
Share on other sites

The latter. I think the plan is the use two of these (with washers) for the rear and the two rear bolts for the front.With tax the bolts work out to around $6.50 each. I have no idea what the cheapest shipping around the country would be, probably regular parcel post for most places.

That's a pretty good price! You're sure they are the length you think they are? When you eventually get them, we have enough interest in the Ottawa area that we should be able to ship a single package, then split it up locally to save on shipping.

Share this post


Link to post
Share on other sites

Installed Brabus fuel rail cover on my US spec Brabus coupe.Photo did not load.

Edited by Z06-LITE

Share this post


Link to post
Share on other sites

Looks good! Mine is waiting to get bodged into my cdi... ;)Around $17 at Canadian dealerships, took less than a week to get from Stuttgart. In case you were wondering.

Share this post


Link to post
Share on other sites

That is very cool, Z06. I would be interested in finding a BRABUS SD-1 intake plaque but those are rarer than rocking horse poo.

Share this post


Link to post
Share on other sites

They are, and the few I've seen for auction look like shiite, with prices not based in reality.The 451 gasser cover is actually nicer, but it will take a fair amount of careful trimming to get it to fit just right.

Share this post


Link to post
Share on other sites

M-B called to let me know my car is fixed. Now to see how long this brake lamp switch will last.

I pulled the bill for my last switch, 33 months ago & now when it gets below -20° C the ABS/ESP lights are on but once above that they go out. Just started this last week, I'm thinking of installing a heater in the plastic cover. ;)

Share this post


Link to post
Share on other sites

Had a pretty good night tonight and decided to give the Brabus some love

[*]Pulled the clutch actuator cleaned it and greased it up then reinstalled.

[*]Clutch teach in and drag point with the star machine.

[*]Oil change with 5w40 synthetic and filter

[*]K&N Air Filter recharged

[*]Greased all the suspension joints

[*]Changed the break fluid with DOT 4 fluid, also opened the valves on the ABS pump via star machine

[*]Cleaned out the rear drums and checked for wear

[*]Adjusted my headlights, my drivers side light was way out of wack

[*]Checked for any faults, no codes/faults on the star :thumbsup_still:

[*]Also checked the intercooler fan via star still works.

[*]Wash & wax

[*]Interior vacuumed, carpet cleaned, armourall'ed and all glass cleaned

A non related note I can finally crack open victory drink! Just completed my latest resort project, 254kw/hr @ Wyndham Dominicus Palace in the DR B)

post-12052-1390885933_thumb.jpg

post-12052-1390887273_thumb.jpg

Edited by dmoonen

Share this post


Link to post
Share on other sites

Yeah got stuck in the Esso car wash for half an hour in the coupe before work. Apparently it's so light it causes errors that cause it to spew out bright coloured foam constantly and doesn't let you escape. Certainly an interesting experience. :rolleyes: On the bright side its really clean and no road salt!Serves me right for not giving the coupe the TLC the Brabus gets.

Edited by dmoonen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

    Chatbox
    You don't have permission to chat.
    Load More