Sign in to follow this  
Followers 0
Ghost

No instruments, no turbo?

5 posts in this topic

Hi there!My radio died today - took it out to check the wires for installation of a new one, and had a shortage somewhere (just a little spark for a second).Problem now - I lost all my instruments, rpm doesn't work, display shows no heat, no fuel, no gear, it shows the kilometers but is not counting. Interior light is dead as well. Just drove the car, and clearly - I lost power. Seems that the turbo does not kick in..... does that make sense???What the hell did I do there???Oh, I am talking about a 2005 CDI.Thanks,Ghost

Share this post


Link to post
Share on other sites

Hi Try checking your fuses. There are a lot of things interconnected on the smarts. Alan

Share this post


Link to post
Share on other sites

Well if you made a spark, I'd say it's pretty much guaranteed a fuse has popped. Seeing as that's exactly what they're meant to do in that situation.

Share this post


Link to post
Share on other sites

2 Fuses were gone....... cheap and fast fix, 2 dollars and 2 minutes! Car is back to "normal".Thanks for the hint!No instruments - connected to a broken fuse - logical. I just did not expect that a loss of power could be connected to a broken fuse as well.Now i know!Ghost

Share this post


Link to post
Share on other sites

Radio fuse also controls the ABS - blow that and you go into limp mode - don't ask me how I found out a day ahead of when we were supposed to go on a trip! Cost me the dealer charge to check things and a pair of smart sunglasses to get my wife Gerri happy again.Cheers,Cameron

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

    Chatbox
    You don't have permission to chat.
    Load More