Sign in to follow this  
Followers 0
ebu gogo

New Cruise Control Doesn't Work.

22 posts in this topic

Hi All.I installed my new cruise control stalk & for some reason MB can't get it to work,although, all the other functions do. They tried all their codes & the expensive after market ones they supply.Has any one experienced this problem?The car didn't come with a tachometer either, but I installed it, & it loaded no problem at the dealer.ThanksPaul05 800cc cdi

Share this post


Link to post
Share on other sites

This is the first I've heard of any MB dealer attempting to activate cruise in a 2005-2006 fortwo. There is no such thing as an "aftermarket code".

Share this post


Link to post
Share on other sites

I think Steven supplied them with a bunch of MDC cruise units. Maybe they still have some.

Share this post


Link to post
Share on other sites

The MDC cruise - I have one from Steven since 2005 - is simple plug-n-play and needs no TAN or other codes to install. All the software resides on the PCB that is plugged in behind the heel of the accelerator pedal. We must be talking about the OEM cruise that requires the TAN activation. Has anyone else had the dealer do CC TAN activation? I thought they didn't do this because of some Transport Canada non-compliance regarding LED indicators or something?Paul, did you buy the stalk as an item compatible with European factory cruise and MB is trying to activate it with an EU TAN code? Or did you buy the MDC cruise kit whose stalk works with the MDC plug-in module? Maybe MB is trying to activate an MDC stalk with OEM TAN, or vice-versa, neither of which would work, AFAIK.Bil :sun:

Edited by bilgladstone

Share this post


Link to post
Share on other sites

The B Class has OEM cruise with no indicator on the dashboard or instrument panel to show that it's engaged. So the lack of an LED was not the reason that Canada did not get smart OE CC.I think the Kelowna dealer sold the MDC for a while and the OP seems to be suggesting that they tried to make that one work.

Share this post


Link to post
Share on other sites

I think I am recalling correctly that there was an unacceptable percentage of MDC cruise units that failed; that returns were a nightmare, and that Steven often made one workable kit out of 2-3 failed units.It's doubtful that MB has the capability to diagnose and repair these units, and that in order to get it going, they may have to go through a couple more physical kits to find one that works.But we are speculating. Maybe Paul can tell us what's going on.B :sun:

Share this post


Link to post
Share on other sites

I have the install and user guide for the MDC cruise control - PM if you figure that would help.The reason they didn't introduce the factory cruise here was something to do with the do not exceed this speed setting or something (i.e. speed goverened to a user set point).Cheers,Cameron

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hi all. Thanks for the responses. For some reason I couldn't post this reply the last few times I tried.

So to get every one on the same page, here's the events as they played out.

I bought the stalk here:

http://www.smart-parts-direct.com/cgi-bin/...a307CPE#a307CPE

I then installed it as per Eviloution:

http://www.evilution.co.uk/index.php?id=337

As per the instructions, I made an appointment at MB

as they had to download the codes which were only active for 4 hrs.

The codes didn't work.

They then called me later in the week & said they had some non OEM, non Trans. Can approved, codes

that may work. $250. No guarantees.

So I went for it & they tried all the codes they had but they don't make it active, & they don't know why.

Thanks

Paul

Edited by ebu gogo

Share this post


Link to post
Share on other sites

So it's definitely TAN cruise. The only thing I can suggest is going to someone who has done it many dozens of times, like Eddy in Richmond. I have no idea what he would charge to load an existing TAN, but as you say, it may have expired.

Share this post


Link to post
Share on other sites

Sounds to me like they are using an older cloned TAN calculator -- which stopped working a couple of years ago -- but I still don't get how a Mercedes-Benz dealership would be doing this. Canadian dealerships simply don't install non-approved TANs. They could get in a lot of trouble from Stuttgart.

Share this post


Link to post
Share on other sites

I suspect that Kelowna smart Centre has gotten numerous requests for cruise control and some pencil-neck over there made this unauthorized foray into the grey market to see if he could figure out how to make the company a bunch of extra money.I also doubt that the effort was actually condoned by the Operations management. And to charge Paul $250 for a shot-in-the-dark that failed... I feel that's pretty unethical, if that's how it played out. Bizarre! Someone went "off the reservation" as far as I'm concerned.Bil :sun:

Share this post


Link to post
Share on other sites

They would have paid something for the TAN unless they have one of those illegal generators, so that would be where the charge came in.

Share this post


Link to post
Share on other sites

Hi You all. Thanks again for your responses.Just to keep the topic on thread; I have no issue with MB for not being ableto get the codes to work. I contracted them to do a service for me & they did it.They showed me the OEM codes on their print out & I watched through the servicewindow as they tried them. I did not authorize them to trouble shoot the problemso don't have a problem with paying shop fees for the basic task I paid them to preform.As for the second set of codes, again, it was my choice to pay them to try them.That said, of course I'm kinda bummed about having puked out hundreds of dollarsfor nothing, but I think the main point still remains of how to get it working. Thanks to BIL for sending the link to the shop in Richmond.My original intent was to save $$ on my daily commute as the round trip is about 125 kil per day.Seems if I have to spend a weekend on the coast & pay more shop fees, it's going to take anawful long time to recoup the cost of the whole incident.I haven't contacted them yet to see what they think my options might be but thank you allagain for the info.Paul

Share this post


Link to post
Share on other sites

I have the install and user guide for the MDC cruise control - PM if you figure that would help.The reason they didn't introduce the factory cruise here was something to do with the do not exceed this speed setting or something (i.e. speed goverened to a user set point).Cheers,Cameron

That might help me delve into in on my own.Thank You.Is it digital data or a book & how can we arrange for me to view it?Paul

Share this post


Link to post
Share on other sites

Mister Dot Com cruise control is not the same as the one that uses TAN codes. Just in case you weren't aware of that...

Share this post


Link to post
Share on other sites

I'm very surprised that a MB dealer would even attempt that. A few years back, tried and tried to get MB on Broadway, in Vancouver to enable the outside temperature sensor, but was told that they had checked, but that it was not possible for them to do it because it had not been ordered at the factory.

Share this post


Link to post
Share on other sites

Yeah, I hypothesize that it was an overzealous tech with an I-think-I-can attitude; maybe the FNG? B :sun:

Share this post


Link to post
Share on other sites

Mister Dot Com cruise control is not the same as the one that uses TAN codes. Just in case you weren't aware of that...

Thanks Mike.I wasn't aware of that.I'm not sure if I have one or not, but if I did; What would I do about it?

Share this post


Link to post
Share on other sites

MDC cruise has an extra plug in the accelerator pedal module, to which the OEM plug goes into. From your description above, you were definitely trying to activate OEM cruise!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

    Chatbox
    You don't have permission to chat.
    Load More