Sign in to follow this  
Followers 0
joey

Fuel/water separator light on at start-up

6 posts in this topic

I have a 2006 CDI. The fuel/water separator light came on after I filled up a few weeks ago. I changed the filter/separator and the light went out. My question is, when I turn the ignition key to the first position, there a "ding-ding" chime sound and the fuel/water separator light comes on then goes out after about three seconds. Is this normal? I don't recall whether it did this before or not - I've only had the car since June.

Thanks.

Share this post


Link to post
Share on other sites

mine stays on all the time i changed the water separator and used the old sensor still the light is on????

Share this post


Link to post
Share on other sites

up date

pulled out the battery yesterday there was a wire harness coming from the e box with a white connector at the end it was not connected to the connector on the other side so i just put it back in and baam!!! no more water separator light!

it was really annoying to look at!

checked the wires also they all looked good

thanks for the info great site and very helpful

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

    Chatbox
    You don't have permission to chat.
    Load More