Shogun

Universal diagnostic tool for Smart

99 posts in this topic

Ok, I am confused! I have an 05 Passion diesel...is this unit any good for that car? I have a laptop with dvd/cd and Windows XP. If actually any use, could someone send me order info?

IMO its basically only good for

..reading and erasing abs/esp codes

..reading and erasing srs (airbag) codes

..resetting cluster wrench service warning

..cluster lcd display test which is basically useless

it will read and erase engine codes but im assuming most of us already have obd2 code readers and scan tools for that

for $40 its worth it to some people...not for others ...for me it was worth it because my regular scan tool does not do airbag srs systems

i cannot see any other usefullness for this tool on canadian 2005-2008 diesels

Edited by LooseLugNuts

Share this post


Link to post
Share on other sites

It work with a lot of others car, can be usefull.

Yes, I can now read most of my lorries.

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

no

edit :for diesel i mean ...i didnt see the petrol part of the question before answering :lookaround:

Edited by LooseLugNuts

Share this post


Link to post
Share on other sites

Hi Shogun,

I sent you a PM, but didn't get a reply, so I suspect you didn't see it yet. I need help activating the DS150E software, please?

Share this post


Link to post
Share on other sites

Hi guys,

So I bought this toy as well. Somehow managed to activate the software (2013.3) and read some codes, but could not find any way to perform any kind of adjustments, like edit various parameters, run clutch calibration, etc.

Edited by TorqueJunkie

Share this post


Link to post
Share on other sites

You can adjust clutch electronically by reading your Roadster as a Smart 450 of same age.

Share this post


Link to post
Share on other sites

ive only been able to read and erase codes (engine-brakes-srs)...reset service wrenches....and view data....have never seen any way of adjusting clutch electronically

ive only used it on a 2005 coupe and a 2005 cabrio (diesel canadian models of course) ...i did notice that on the cabrio i cannot connect to the brake/abs/esp system..it always rejects connection but works fine on the coupe

mine is a 2013 release 3 version ...maybe we have different versions?

Edited by LooseLugNuts

Share this post


Link to post
Share on other sites

There is not much Delphi DS15E can do on a diesel 450 but can code keys from 2003 on.

Share this post


Link to post
Share on other sites

Thank you tolsen, once again you save my ass. The function is quite well hidden and first time user has to do some (right)clicking around.

I have successfully reset clutch learning and then recallibrated drag and contact points (two different procedures). It can also calibrate gear position sensor and cycle clutch actuator for several minutes for inspection.

The box was two times cheaper than the no-name shop charges for the procedure. So it paid for itself twice in a single try. Nice.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks LooseLugNuts! I would have never been able to figure out this installation without that video!

I got thru the installation tonight, tomorrow I'll try it out in the car and see what I can accomplish. The main items to be done are resetting the airbag light and check calibration of the clutch.

Share this post


Link to post
Share on other sites

Hello,

Well, it wasn't easy, but I got everything connected to my Smart and recognized by the software. Now I can't figure out how to do anything with it. Where do I go?

Share this post


Link to post
Share on other sites

You first need to find a device thee, then select your ECU in it and then right-click. Very weird placement of a function, as if they wanted to hide it from us.

Share this post


Link to post
Share on other sites

Hello,

I see the device tree, but I don't see any ECU's in it... there's a list of all the systems, with a red icon in front of them; when I click on one, it opens up a sub menu, and on and on. I'm really only interested in resetting the airbag light right now, so I was trying to right click on the "restraints" system, but it just comes up with "COLLAPSE ALL". Same when I right click on any of the other line items.

All I seem to be able to do well is go into demo mode and run them.

Can you provide more detailed instructions?

I have my model, engine type, etc,all entered into the vehicle information screen already.

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

to reset airbag light I open the program..then choose smart 450

then on bottom right i click the curved arrow to enter ISS

i choose diesel and make sure all the others are clicked and do a complete scan (by clicking on the arrow in bottom right)....then i will read and erase codes for each system individually

the srs codes will of course be listed under restraints system

Edited by LooseLugNuts

Share this post


Link to post
Share on other sites

Hi

When I enter ISS it goes into ISS-Demo, is that correct?

Then it runs the search, and I get "No system responded" in all of them. Any suggestions?

Everything I try to do seems to go into Demo mode.

Share this post


Link to post
Share on other sites

Hi

When I enter ISS it goes into ISS-Demo, is that correct?

Then it runs the search, and I get "No system responded" in all of them. Any suggestions?

Everything I try to do seems to go into Demo mode.

You have not selected any hardware in setup so Delphi will always default to demo mode.

Share this post


Link to post
Share on other sites

Hi Tolsen,

Yes, I have selected the hardware, by clicking on each item on the screen. Do I need to do anything else in order to select the hardware or that's it? I'll try to post a picture of my screen. All I can do is go into the demo modes.

Share this post


Link to post
Share on other sites

Hi tolsen,

You were correct, i unchecked it now, and i am not going into demo mode any longer.

Now i cannot establish communication. I have tried unplugging and restarting everything in various ways and sequences without success for about one hour, very frustrating i must say.

Any suggestions?

Thanks for your help.

Share this post


Link to post
Share on other sites

Not much one can do.

Go to settings and search for multiplexer. Test from settings when found.

Then try reading your Smart.

DelphiVCI.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

    Chatbox
    You don't have permission to chat.
    Load More