booneylander

How much boost triggers overboost-code?

8 posts in this topic

Just wondering if anyone knows off hand what MAP reading triggers an over-boost code?

Both my coupe and the girlfriends' cabrio are maxing out at about 30.5 psia. I'm wondering if I might be able to adjust my wastegate to get a bit more boost without triggering a CEL and limp mode. The map in the cabrio is fine but the map in the coupe is just smokey enough to bother me. Interestingly, when I'm running biodiesel it doesn't smoke, but on pump-diesel, it smokes. Less power on bio, granted. Anyway, just trying to figure out if I could clean it up with some more boost or whether I should re-map the coupe for a bit less power so that I don't get the smoke.

Share this post


Link to post
Share on other sites

Good info guys, thanks!

Sounds like I could squeeze a bit more out of it.

The car I'd be adjusting is my coupe that's still on stock turbo, not the cabrio I just put the cartridge into, so it should be "settled in" for me to make adjustments.

And it's not normally smokey, just when I'm on the gas hard enough to be at or near full boost. Like if I'm merging onto the highway, or there are a few spots around here where I'm turning onto an 80kph road, with most people going 100kph, and the road is blind on one side so I'll be coming up to speed normally when I spot someone coming over the crest and I have to put my foot in it. In those cases it leaves just enough smoke that it's visible in the mirror, and I don't like it.

Anyway, worth a try I think.

Share this post


Link to post
Share on other sites

Both of mine boosted to 2.2 bar, which is just under 33 PSI so that sounds like a good idea. Neither ever had an overboost warning, in 355,000 km.

Share this post


Link to post
Share on other sites

Correct. A good way to determine boost is to measure the MAP at idle and then subtract that from MAP when at maximum boost. But it's just as easy to quote MAP because that's what the ECU uses for fueling and suchlike. The highest MAP I have seen is 2.22 when it was 1.0 at idle. Nominal maximum is 1.15 bar.

Share this post


Link to post
Share on other sites

I adjusted my wastegate a little bit, brought max boost up to 32.8psi from about 30.2psi MAP. Seems to have cleaned things up a bit, but we'll see once we have a few more super hot days.

Share this post


Link to post
Share on other sites

The same will happen with some of the other codes, EGR fault being one of them, the ECU will reset the CEL after a certain number of start/stop cycles without an error. The code will still be stored in memory until cleared even if the CEL is out. Maybe not accessible using Scangauge or similar tool, but the Mercedes Star tool should pull the codes out of memory.

Sounds like your wastegate is probably sticking shut every now and then, rather than a MAP sensor fault. If you have a Scangauge (or similar) tool, display the MAP reading while driving to see if it is behaving normally, and note your max value under normal driving. If you get something around 14.5psi with the key on engine off, and something in the 28-33psi range at full throttle over 2500 rpm, then I would suspect that your MAP sensor is fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

    Chatbox
    You don't have permission to chat.
    Load More