14 posts in this topic

can anyone help?

my smart city passion 2003 has one headlight lamp not working, i have taken the front off the car and taken both lights out, I swapped them over and the faulty one worked fine on the other side.

Share this post


Link to post
Share on other sites

Wiring or relay failures like this happen on these cars.  Best to install an external relay in line with the functional wiring.  The functional headlight wiring will operate the relay coil, 12V from the battery through the relay will power the headlights.  Fuel pumps on the cdi can also benefit from the addition of a relay to remove the excessive draw through the SAM.

 

http://clubsmartcar.com/index.php?/topic/28124-fuel-pump-upgrade/

Share this post


Link to post
Share on other sites

Thanks Huronlad, I will give that some thought, sounds a bit complicated! Would tou have a witing diagram?

Share this post


Link to post
Share on other sites

Regrettably, description of code designations is all in High German.  

Share this post


Link to post
Share on other sites
2 hours ago, tolsen said:

Regrettably, description of code designations is all in High German.  

For some obscure reason, drawing for my 2002 Cabrio has above description in plain English.  This will help with most of the code designations.

 

 

Wiring diagram of exterior lightsMineFTP.pdf

Share this post


Link to post
Share on other sites

HI all,

 

finally had the stalk changed but unfortunately no luck, still have a problem, over the last week prior to changing the stalk all the lamps on the drivers side front light have stopped working!! previously it was just the headlight.

 

any ideas guys?

Share this post


Link to post
Share on other sites

SAM problem I am afraid (assuming 2003s have a SAM).

Share this post


Link to post
Share on other sites

electrical processing unit - the car's brain.

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

its the fuse box thing above your left foot 

 

the headlight wires are in the middle of the brown plug when you lower the fusebox youll see the brown connector on the back of it...undo it and see what you see

 

just saw the england part..not sure which foot its under if right hand drive model

Edited by LooseLugNuts

Share this post


Link to post
Share on other sites

Will be above passenger's feet if a UK model. 

Share this post


Link to post
Share on other sites

hi all,

 

thanks for the assistance, i went to a garage in the end and it is a fault with the smart box!! apparently there is an output when you test the wiring but as soon as you turn the dipped beam on the drivers dipped beam fails.

 

i think I will just sell the car as i don't want to pay out another £400-£500 on a car that was only worth £1000.00, it's a real shame.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

    Chatbox
    You don't have permission to chat.
    Load More