Dali555

Engine or front end problem?

3 posts in this topic

Last year driving my 2008 I all of a sudden had no power, couldn’t get above 10 miles an hour. Unfortunately I had to let it sit because of funds. When I went to move it recently it wouldn’t move at all so I went drive then reverse and after a few tries it “broke” free. Now it sounds like the brakes are locked and it scratches metal on metal while driving. Went up my hill and it kinda sputters with the power now. I did notice a very small puddle of some oil on my passenger side front rim. Is my axel shot? Could that have been my problem last year with loss of power? Thanks in advance everyone!

Share this post


Link to post
Share on other sites

Did the check engine light come on last year when you lost power?  If the car has been sitting a year, front disc brakes will rust up.  A front bearing would not leak an oil like substance, could be a brake fluid leak.  The car need to be looked at by a competent individual. 

Share this post


Link to post
Share on other sites

No check engine light. Yeah, I’m going to centrally bring it to a mechanic, just figured I’d ask in case someone had the same issues

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

    Chatbox
    You don't have permission to chat.
    Load More