Sign in to follow this  
Followers 0
Goat55

2010 smart for two --passion

2 posts in this topic

Question ,I bought this car about a year ago, it has low miles about 35,000 now. When i first stated driving the starter motor would run for about 10 seconds after the car started. now recently it will keep going for 30 seconds or longer or sometimes until i shut car off and restart. any thoughts? sticky relay or? has a relatively new battery-1 yo

 

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hello Goat,

Hope I can help.

I do not have this problem on my smart but I have had a similar problem on my diesel vehicles, Mercedes and GMC. In each case, I replaced the solenoid after cleaning that area and greasing it lightly.  In some cases, I just took the entire solenoid apart and cleaned it.  With bigger trucks solenoids are available but expensive, so it was worth it to do this with the GMC trucks.  I don'r know how available the smart car solenoids are, so it might be worth it if you can take your time and work on the smart.

Hope this helps.

Edited by strelnik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

    Chatbox
    You don't have permission to chat.
    Load More