gtjunk

Oil pressure sensor connector (451)

7 posts in this topic

Posted (edited) · Report post

I'm working on getting my spare 451 running again and making good progress; however, when the serpentine belt went out it took the oil pressure sensor plug with it. I have part of a spare harness, but the same connector on it is broken as well.

 

The plug/connector is a waterproof design with the intergal seals to keep grud out and looks like this:

 

OPS-062-14803.png

 

Any of you have an idea of where I might find a replacement connector that doesn't involve acquiring and chopping up another harness?

Edited by gtjunk

Share this post


Link to post
Share on other sites

Update, I reached out to a friend who's better at finding odd parts than I am. In relatively short order he came up with 1J0973701A as an Audi part that seems to be a match for the oil pressure sensor connector.

Share this post


Link to post
Share on other sites

It's an Oil Pressure Sending Unit - Smart (001-153-06-32) according to Mercedes....:)

Share this post


Link to post
Share on other sites

Something obviously lost in translation. 

 

Only a single cable connected hence can only be a pressure switch. 

Share this post


Link to post
Share on other sites

And a normally closed pressure switch according to post number 1. 

Share this post


Link to post
Share on other sites

Good grief, it is of course a sensor AND a switch.  Smart people know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

    Chatbox
    You don't have permission to chat.
    Load More