Sign in to follow this  
Followers 0
shung

How-To: Reset the Service Indicator

45 posts in this topic

i have followed instructions to change it from B to A service and it will not change shows as follows:2 wrenches and 8,000kms. Only problem I just had a B service done and need to change it to a A again.

Share this post


Link to post
Share on other sites

Don't worry about the wrenches. The fact that you got it reset to 8,000 kms is all that really matters. You can remember when it comes due whether it is an A or B.

Share this post


Link to post
Share on other sites

Does anyone know if this will work on a 451 as well?

nevermind.. I just tried and it works, thanks. Edited by denisjolicoeur

Share this post


Link to post
Share on other sites

Hi I have a 2006 disel and have installed a new oil pan with drain plug. I tried to reset the service reminder program following the instructions but it would not reset. Is there another set of instructions I coud try. , Thanks. Ben

Share this post


Link to post
Share on other sites

Hey Ben, there is the old adage, "if at first you don't suceed, try, try again"It usually takes a couple of tries for the reset to work. Also, the timing of the steps is touchy.MG

Share this post


Link to post
Share on other sites

Ok Smarties, I changed the oil at Lubexx in St. Albert and I am trying to reset the maintenance indicator. However my numbers coming up are -42. I get the flashing wrenches at the start of the procedure. Turn off the ignition, then turn on the ignition while holding down the reset button just reset the fuel status back to zero. I have tried the process a half dozen times. Dealing with a 450 2006 smart pulse with 20,000 km. I have gone through the reset procedure about a dozen times. What should it look like when it is properly reset? The Smart owners manual talks about 500 km to go to oil change etc.Rocky

Share this post


Link to post
Share on other sites

Once reset, it should show 8000 km.

Share this post


Link to post
Share on other sites

Does anyone know if the "U.S. ized" cars can be reset by Shung's process? I haven't been able to get it to reset. The single wrench came on at 10,000 miles (showing 100 mile increments leading up to that number). Now it is showing negative numbers - I'm at -1000 miles. I've tried several times - when I get to #5 in Shung's instructions the wrench will go out momentarily and the -1000 will go away. But it shows up again later when starting the car.

I think it does not work on G&K conversions...... Edited by SCHMART

Share this post


Link to post
Share on other sites

I just realized these messages we're replying to are 6 to 9 months old... aargh..... deleted........

Edited by smartzuuk

Share this post


Link to post
Share on other sites

What is the instrument cluster (service) button? Is this the one for re setting the trip meter? or is there a hidden one that I cannot see?

Share this post


Link to post
Share on other sites

No, you're correct -- it's the one on the left oft the housing that you use to cycle through the trip meter, odometer, fuel and temperature.

Share this post


Link to post
Share on other sites

Update for G&K gassers..I spoke with ed the tech guy at G&K and he said follow the Canadian instructions, but you must get the first step at 2 seconds, shut off and at 2 seconds turn back on while holding the reset button and continue to hold in until wrenches dissapper then shut off..IT WORKED!!!!!YIPPIE..even with these instructions it worked on the 13th try....good luck it can be done

Share this post


Link to post
Share on other sites

I just changed my oil and it took longer to reset the service indicator. The most important part is what SCHMART said in the post above

you must get the first step at 2 seconds, shut off and at 2 seconds turn back on while holding the reset button

When I did it within 2 seconds it worked first try. Hopefully, this will help someone else.

Share this post


Link to post
Share on other sites

I guess I was quick and lucked out the last time when I reset my service indicator. This time I spent nearly as much time trying to reset it as I did with the actual oil change. :banghead:

Sure enough, I came back to this topic to express my frustrations, read the most recent posts, tried it again using the TWO SECOND RULE ---- and found that it worked perfectly. :)

I'm wondering if the original post in this topic by shung can have an 'Edit' note attached to the bottom of it to indicate that steps 2, 3 and 4 should each be done within 2 seconds. It might save a lot of members a lot of grief. Moderator??

Thanks SCHMART for posting the solution.

Share this post


Link to post
Share on other sites

This thread should be pinned.

Share this post


Link to post
Share on other sites

This thread should be pinned.

It's been in the how to tutorial since 2007:

Software Tricks and Hints

How-To: Program your Scangauge to work on the smart cdi - smartzuuk

How-To: Reset the Service Indicator - shung

How-To: Turn off Daytime Running Lights - Adrian

How-To: Turn on Sound Upgrade - I M SMRT

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

    Chatbox
    You don't have permission to chat.
    Load More